体育平台

Debian下手動安裝LiteSpeed+PHP+MySQL教程

Debian系統一直是微魔和喜歡的Linux分枝,最小化的系統占用系統資源非常的少,而且操作起來也很簡單。之前陸陸續續的折騰了一下LiteSpeed,最近就把一些手動安裝的心得貼出來和大家分享吧,如果實在懶得動腦,可以參考之前的文章,使用llsmp一鍵安裝包。下面開始安裝!

  1. 清理Debian,去除不必要的軟件包
  2. 安裝MySQL及相關的庫文件
  3. 安裝LiteSpeed
  4. 編譯PHP
  5. 配置eAccelerator
  6. 安裝Zend Loader

1.清理Debian,去除不必要的軟件包

apt-get update
apt-get -y purge apache2-* bind9-* xinetd samba-* nscd-* portmap sendmail-* sasl2-bin
apt-get -y purge lynx memtester unixodbc python-* odbcinst-* sudo tcpdump ttf-*
apt-get autoremove && apt-get clean

2.安裝MySQL及相關的庫文件

apt-get remove apache
apt-get update
apt-get upgrade
apt-get install autoconf gcc g++ libjpeg62-dev libpng12-dev libxml2-dev curl libcurl4-openssl-dev libmcrypt-dev libmhash-dev libfreetype6-dev patch make mcrypt mysql-server libmysql++-dev zlib-bin zlib1g-dev

設置autoconf

export PHP_AUTOCONF=/usr/bin/autoconf
export PHP_AUTOHEADER=/usr/bin/autoheader

安裝時中途會詢問MySQL的密碼,連續輸入兩次即可

3.安裝LiteSpeed

訪問LiteSpeed官網獲得最新版本的下載鏈接:http://litespeedtech.com/litespeed-web-server-downloads.html

cd /tmp
wget http://litespeedtech.com/packages/4.0/lsws-4.1.13-std-i386-linux.tar.gz
tar zxvf lsws*
cd lsws*
sh ./install.sh

出現許可協議,只需持續按下【空格】鍵到最后,輸入Yes(注意Y大寫)

交互回答如下問題

Destination [/usr/local/lsws]: 回車
User name [admin]:管理員賬號(默認admin)
Password:管理員密碼
Retype password:密碼確認
Email addresses [root@localhost]:你的郵箱
User [nobody]:默認,直接回車
Group [nogroup]:默認,直接回車
HTTP port [8088]:寫80
Admin HTTP port [7080]:Litespeed面板端口,可默認,直接Enter
Setup up PHP [Y/n]:默認,直接回車
Suffix for PHP script(comma separated list) [php]:默認,直接回車
Would you like to install AWStats Add-on module [y/N]?默認,直接回車
Would you like to have LiteSpeed Web Server started automatically when the server restarts [Y/n]?默認,直接回車
Would you like to start it right now [Y/n]?默認,直接回車

此時不要關閉SSH窗口,后面還要用到~

4.編譯PHP

訪問litespeed管理后臺:http://ip:7080

點擊Actions->Compile PHP

選擇PHP版本,點擊Next(我選擇的是5.3.15)

在編譯參數中填寫為如下段,

'--with-pdo-mysql' '--with-mysql' '--with-mysqli' '--with-zlib' '--with-gd' '--enable-shmop' '--enable-track-vars' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-magic-quotes' '--enable-mbstring' '--with-iconv' '--with-litespeed' '--enable-inline-optimization' '--with-curl' '--with-curlwrappers' '--with-mcrypt' '--with-mhash' '--with-mime-magic' '--with-openssl' '--with-freetype-dir=/usr/lib' '--with-jpeg-dir=/usr/lib'

小內存VPS在編譯的時候,會出現內存不夠的問題”virtual memory exhausted: Cannot allocate memory”,此時在參數欄處再上如下參數,重新編譯一下應該就OK了~

--disable-fileinfo

下面可選安裝組件,我只選擇了eAccelerator;

點擊Build PHP 5.x.x

LiteSpeed開始下載包,下載完成后,點擊Next

此時不要刷新頁面!

在SSH運行如下命令:

/usr/local/lsws/phpbuild/buildphp_manual_run.sh

直到瀏覽器提示“*Complete*”就算是大功告成了~

5.配置eAccelerator

PHP雖然安裝好了,但之前我們選擇的eAccelerator還需要配置一下

創建eAccelerator的緩存目錄

mkdir /usr/local/eaccelerator_cache
chmod -R 777 /usr/local/eaccelerator_cache

編輯php.ini

cp /usr/local/lsws/php/php.ini /usr/local/lsws/lsphp5/lib/
vi /usr/local/lsws/lsphp5/lib/php.ini

在php.ini后面加入如下字段

[eaccelerator]
zend_extension="/usr/local/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20090626/eaccelerator.so"
eaccelerator.shm_size="1"
eaccelerator.cache_dir="/usr/local/eaccelerator_cache"
eaccelerator.enable="1"
eaccelerator.optimizer="1"
eaccelerator.check_mtime="1"
eaccelerator.debug="0"
eaccelerator.filter=""
eaccelerator.shm_max="0"
eaccelerator.shm_ttl="3600"
eaccelerator.shm_prune_period="3600"
eaccelerator.shm_only="0"
eaccelerator.compress="1"
eaccelerator.compress_level="9"
eaccelerator.keys = "disk_only"
eaccelerator.sessions = "disk_only"
eaccelerator.content = "disk_only"

這時,可以打開http://ip/phpinfo.php看看eAccelerator安裝的如何~

6.安裝Zend Loader

wget http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz
tar zxvf ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz
mkdir -p /usr/local/zend/
cp ZendGuardLoader-php-5.3-linux-glibc23-i386/php-5.3.x/ZendGuardLoader.so /usr/local/zend/

編輯php.ini

vi /usr/local/lsws/lsphp5/lib/php.ini

添加如下字段

[Zend.loader]
zend_loader.enable=1
zend_loader.disable_licensing=1
zend_loader.obfuscation_level_support=3
zend_loader.license_path=
zend_extension="/usr/local/zend/ZendGuardLoader.so"

查看是否安裝成功

/usr/local/lsws/lsphp5/bin/php -v

最后重啟litespeed生效~

/etc/init.d/lsws restart

環境基本配置好了,但是要使用還需要添加虛擬主機等一系列的步驟和過程,微魔會在日后的教程中和大家分享~

本文的撰寫借鑒了多篇網絡優秀文章,感謝百度,感謝google,點名感謝,和,以及一些不知名甚至可能是這些資源原創作者的各位極客~

猜你 喜歡

關于作者: 微魔

小微魔,大智慧!

多條評論

  1. 這篇文章有收藏價值,話說LiteSpeed的文章還真不多見。

    博主辛苦了!博主有錢銀用的是阿里云?

    1. 呵呵,多謝支持~有錢算不上吧,阿里云的價格也還算好吧,關鍵是國內的速度用著舒坦一些~

        1. apt-get install autoconf gcc g++ libjpeg62-dev libpng12-dev libxml2-dev curl libcurl4-openssl-dev libmcrypt-dev libmhash-dev libfreetype6-dev patch make mcrypt mysql-server libmysql++-dev zlib-bin zlib1g-dev
          這句安裝mysql之后,就會有提示輸入密碼的,而且界面是SSH下的窗口模式,應該很明顯的,除非…你的Debian默認安裝了MySQL…如果是這樣的話,一般默認用戶名是root,密碼為空。你可以在ssh下直接輸入mysql看能不能進->mysql模式~記得裝好后改一下mysql的密碼哦。

          1. After this operation, 226MB of additional disk space will be used.
            Do you want to continue [Y/n]?

            Install these packages without verification [y/N]?

            我好像就看見輸這兩個提示

  2. Pingback:
  3. 安裝Litespeed的時候出現
    /usr/local/lsws/bin/lswsctrl: 236: ./litespeed: not found
    [ERROR] Failed to start litespeed!
    [ERROR] Failed to start the web server. For trouble shooting information,
    please refer to documents in “/usr/local/lsws/docs/”.

    1. 我沒遇到這個問題,就你提供的這些錯誤我也沒在網上搜到…確保之前的命令別出錯,系統是Debian等等,要是還出錯,那就沒啥辦法

    2. 我找到原因了,這跟系統有關系,litespeed是要用32位的主機,64位的主機只需要安裝32位兼容庫就可以搞定了,命令:apt-get install ia32-libs

        1. 你把 ia32-libs 安裝起來看看,我一個VPS是32位的,正常安裝,另一個是64位的,安裝這個庫之后就可以了。

      1. Litespeed有專門的64位的版本,在64位的系統上可以安裝那個版本,應該就不必安裝那個ia32-libs那個包了。本文示范的是32位版本

        1. 64位都是收費版的,免費的只有32位的,所以只能這樣子做

          1. 嗯,64位的貌似都是老版本的了,官方頁面寫著“ If you want to run the standard version on 64bit Linux, you need to install 32bit compatible libraries (ia32-libs for Ubuntu/Debian and glibc for CentOS).”

        2. 嗯,是的啊,反正一個兼容包就可以搞定了。不過LiteSpeed的中文資料真心少啊,以前我用的空間商也是基于Litespeed的,所以對這個很有好感,現在自己VPS也就部署了,小站人少用起來感覺挺好的

  4. 在編譯PHP的時候又出現/bin/sh /usr/local/lsws/phpbuild/php-5.3.15/libtool –silent –preserve-dup-deps –mode=compile gcc -I/usr/local/lsws/phpbuild/php-5.3.15/ext/fileinfo/libmagic -Iext/fileinfo/ -I/usr/local/lsws/phpbuild/php-5.3.15/ext/fileinfo/ -DPHP_ATOM_INC -I/usr/local/lsws/phpbuild/php-5.3.15/include -I/usr/local/lsws/phpbuild/php-5.3.15/main -I/usr/local/lsws/phpbuild/php-5.3.15 -I/usr/local/lsws/phpbuild/php-5.3.15/ext/date/lib -I/usr/local/lsws/phpbuild/php-5.3.15/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/lsws/phpbuild/php-5.3.15/ext/mbstring/oniguruma -I/usr/local/lsws/phpbuild/php-5.3.15/ext/mbstring/libmbfl -I/usr/local/lsws/phpbuild/php-5.3.15/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/usr/local/lsws/phpbuild/php-5.3.15/ext/sqlite3/libsqlite -I/usr/local/lsws/phpbuild/php-5.3.15/TSRM -I/usr/local/lsws/phpbuild/php-5.3.15/Zend -I/usr/include -g -O2 -fvisibility=hidden -c /usr/local/lsws/phpbuild/php-5.3.15/ext/fileinfo/libmagic/apprentice.c -o ext/fileinfo/libmagic/apprentice.lo
    gcc: Internal error: Killed (program cc1)
    Please submit a full bug report.
    See for instructions.
    make: *** [ext/fileinfo/libmagic/apprentice.lo] Error 1
    **ERROR** Could not compile PHP

    1. VPS內存是多少的?OVZ還是Xen,貌似這個錯誤也是因為gcc在編譯PHP的時候內存不足造成的,文章里面有提到,可以加個–disable-fileinfo的參數重新編譯一下~

      1. 加入了這個已經編譯完成.謝謝.但是你這個顯示好像有問題.這個代碼應該是兩個 – – 連起來.現在顯示出來是一個-

  5. ?? 稀里糊涂的劇裝完了。。但是數據庫管理的網址是多少啊???

    1. 如果你說的是PHPMyadmin的話,本文沒有安裝,我個人如果是簡單的數據庫命令的話,就直接在MySQL命令行下安裝了,想了解的話,不妨搜索本站。當然,安裝PHPMyadmin本身也不是什么難事,到網上搜一下有的是教程~~

  6. 求教:安裝過程中 PHP應該是成功了的 但是卻報了另外一個錯誤
    請VM幫忙看一下:
    Changing to build directory /usr/local/lsws/phpbuild/php-5.4.13/eaccelerator-0.9.6.1
    Running PHPize for eAccelerator extension
    Configuring for:
    PHP Api Version: 20100412
    Zend Module Api No: 20100525
    Zend Extension Api No: 220100525
    Configuring eAccelerator extension build
    /usr/local/lsws/phpbuild/buildphp_1368269242.9.install.sh: line 165: ./configure: No such file or directory
    **ERROR** Could not configure eAccelerator extension build

  7. Pingback:
  8. Pingback:

發表評論